Please enable JavaScript to view this site.

HDR Light Studio - Documentation

HDR Light Studio is a standalone lighting application providing a set of tools and content dedicated to lighting 3D scenes. Using HDR Light Studio connected to Maya provides the ability to create custom HDRI maps to light your scenes, with lights chosen and positioned to provide the perfect effect on your model. As you work with HDR Light Studio, the lighting is updated in real-time in Maya, where you can see the lighting interact with your 3D scene. You can also create and control Area Lights using HDR Light Studio.

This workflow tutorial will teach you how to use the connection between Maya and HDR Light Studio.
It will not teach you how to use HDR Light Studio itself. Please see our 'Getting Started' content here to learn the HDR Light Studio interface and the basic features.

Workflow Tutorial
Requirements: Maya 2019 / 2020 / 2022 with V-Ray, RenderMan, Redshift, Octane or Arnold. Not your Maya version or renderer? Click here to see Workflow - Method 2

STEP 1: Start Maya and load the Maya project you want to light (see Figure 1).
 
Make sure a camera is set up for your scene and your correct renderer is set. In this example V-Ray is used.

 

Figure 1: Loaded scene in Maya

Figure 1: Loaded scene in Maya

STEP 2: Open the HDRLightStudio Connection shelf
 
If you do not see the HDRLightStudio shelf, click here to see installation instructions.
 
The HDRLightStudio shelf opens (see Figure 2)
 

Figure 2: HDR Light Studio connection tab

Figure 2: HDR Light Studio connection tab

 

STEP 3: In the HDRLIghtStudio connection shelf, click on the 'Start' button (see Figure 3)

 
In order for HDR Light Studio to be started in a connection with Maya and your Renderer, an IBL Hook is required to connect with.

An IBL Hook is simply a valid Image Based Lighting setup (Dome Light / Environment Light), whose HDRI map file can be replaced and updated by HDR Light Studio.

 

Figure 3: Starting the HDR Light Studio connection by clicking on the 'Start' button

Figure 3: Starting the HDR Light Studio connection by clicking on the 'Start' button

STEP 4:  Create a new IBL Hook by providing a name for the hook in the 'Create New Hook for VRay' panel and press the OK button (see Figure 4).

 

During the start process, our plug-in detects if there are valid IBL Hooks, if not then we create one for you.

 

Figure 4: Creating a new IBL hook

Figure 4: Creating a new IBL hook

 
HDR Light Studio will now start, controlling the HDRI image file used on the new IBL Hook, unless there are already valid IBL Hooks in your Maya scene, a dialog will appear where you will be asked to choose a Hook from the drop down, or there is an option to create a New Hook (see Figure 5).

 

Figure 5: Selecting an existing hook before HDR Light Studio connection starts

Figure 5: Selecting an existing hook before HDR Light Studio connection starts

 

HDR Light Studio will then start connected to the hook selected or the new one created (see Figure 6).
 
The HDR Light Studio interface should look like in Figure 6.

If not in HDR Light Studio you can reset it by going to the menu: Window > Layout > Load > Default > Maya

 

Figure 6: HDR Light Studio on start up

Figure 6: HDR Light Studio on start up

 
When the HDR Light Studio Connection starts, a HdrlsProjectData node is added to the Maya scene and can be seen in the Outliner (see Figure 7).

This node stores the HDR Light Studio lighting project within the Maya scene so that the lighting design can be restored in HDR Light Studio in future sessions.

This stores the last state of the project before the HDR Light Studio connection is closed, and of course is only saved when the Maya scene itself is saved.

 

Please note: Using Maya's 'File > Optomize Scene Size' feature will remove the HdrlsProjectData node from your scene. Be sure not to accidentally remove it.

Figure 7: HdrlsProjectData node shown in the outliner

Figure 7: HdrlsProjectData node shown in the outliner

 

The current HDRI map design in HDR Light Studio is shared with Maya as a temp proxy (lo-res) image. A proxy is used because it's faster to calculate and faster for Maya to load during the iterative lighting design process. When the lighting design changes in HDR Light Studio, this image is updated in Maya to use a new temp with a new file name, to ensure the renderer uses the new image even when caching images.

 

The temporary file name and location will look something like in Figure 8 on your IBL dome/sphere. 

 

Figure 8: Location of the temp proxy (lo-res) image

Figure 8: Location of the temp proxy (lo-res) image

 

 

STEP 5: In HDR Light Studio, press Play on Render View [Maya|VRay] (see Figure 9)

 

Figure 9: Starting the V-Ray Render View withing HDR Light Studio

Figure 9: Starting the V-Ray Render View withing HDR Light Studio

 

HDR Light Studio now instructs Maya to start a new session of the Maya Preview Render.

The interactive Preview Render image is now displayed in this Render View (see Figure 10).

To understand all of the features/controls for this view, see here.

 

Figure 10: V-Ray render view working within HDR Light Studio

Figure 10: V-Ray render view working within HDR Light Studio

 

 

Let's make our first light in HDR Light Studio ...

By default, LightPaint is set to Reflection in this view. So lights are positioned to reflect in the chosen location on the 3D model when using LightPaint (see Figure 11).

Learn about LightPaint here.

 

Figure 11: LightPaint mode set to Reflection

Figure 11: LightPaint mode set to Reflection

 

STEP 6: Click on the Presets tab next to the Light List tab, to show the Preset Lights (see Figure 12).

 

Figure 12: Opening the presets tab to see a list of presets

Figure 12: Opening the presets tab to see a list of presets

 

 

STEP 7: Drag and drop a Preset Light onto the 3D model in the Render View [Maya|VRay] (see Figure 13).

 

Figure 13: Placing a preset light onto the model

Figure 13: Placing a preset light onto the model

 

The Preset Light has been added to the lighting design in a location that is reflecting where the light was dropped on the 3D model.

 

A new light in the Light List in HDR Light Studio (see Figure 14).

You can see the new light added on the Canvas (HDRI Map View) in HDR Light Studio (see Figure 14).

The Maya environment has been updated to use the new live HDRI map from HDR Light Studio, and the Maya|VRay Preview Render updated using the new lighting (see Figure 14).

 

Figure 14: HDR Light Studio interface after creating a light

Figure 14: HDR Light Studio interface after creating a light

 

You can see that the LightPaint tool is active in the toolbar within the Render View [Maya|VRay] (see Figure 15).

 

STEP 8: Click on the 3D model to reposition the selected light from the Light List (see Figure 15).

The light is moved on the HDRI map, the new HDRI map is sent to Maya and the Preview Render updates.

This is a very interactive way to light your shot. Placing lights directly on the 3D model where you want them.

 

Figure 15: Using LightPaint to paint lights on the model

Figure 15: Using LightPaint to paint lights on the model

 

If there is a delay of more than a second, or so, after clicking to move a light and see the updated rendered result - the process will be slow and tedious.

In this situation we can use HDR Light Studio's built in renderer to speed up the lighting process.

 

STEP 9: Press the play button on Render View [HDR Light Studio] (see Figure 16)

 

Figure 16: Starting up HDR Light Studio Render View

Figure 16: Starting up HDR Light Studio Render View

 

The Import Scene Geometry panel will pop up

 

STEP 10: Press Import (see Figure 17)

 

Figure 17: Importing the scene from Maya to HDR Light Studio render view

Figure 17: Importing the scene from Maya to HDR Light Studio render view

 

 

You may need to use the Camera Drop Down in Render View [HDR Light Studio] to match the camera view you are seeing from Maya (see Figure 18).

 

Figure 18: Maya|VRay render view (left) and HDR Light Studio render view (right) side by side

Figure 18: Maya|VRay render view (left) and HDR Light Studio render view (right) side by side

 

The Render View [HDR Light Studio] renders the loaded scene lit with the current lighting design. A simple shader is used on the whole scene to preview the light and reflections.

If you needed to open Render View [HDR Light Studio] to get a more interactive lighting experience. Use this view for LightPaint, where clicking and dragging to position lights is supported - it's fast and interactive.

The Render View [Maya|VRay] rendering will catch up eventually as you work, and will display an image using the latest lighting.

 

If the Render View [Maya|VRay] is still so slow that it is of little benefit during the interactive lighting process, and maybe it is also slowing down HDR Light Studio a lot, then use the Pause/Play button to stop and resume rendering in Render View [Maya|VRay], in order to do test renders from time to time (see Figure 19).

 

Figure 19: Pause / Play button for the render view

Figure 19: Pause / Play button for the render view

 

We have documented in more detail the process of using 2 render views together in HDR Light Studio here.

 

So far the light we created is on the HDRI map. With a single setting, this light can be removed from the HDRI map, and created as an Area Light in 3D space in Maya, mapped with the HDR content from HDR Light Studio.

 

STEP 11: Enable the Area Light check box in the Light Properties panel for the selected light (see Figure 20).

 

Figure 20: Converting a light into an area light

Figure 20: Converting a light into an area light

 

As a result of enabling the Area Light setting, these things instantly happen:

•   The Light in the Light List gets the suffix [AreaLight] and the text is now yellow - clearly showing which lights are Area Lights (see Figure 21).

•   The light is removed from the HDRI map lighting the Render Views (but is still represented and shown on the Canvas) (see Figure 21).

•   A 3D Area Light mapped with the HDR light content (RGBA) is created in HDR Light Studio with a Smart Dolly distance of 1,000 (see Figure 21).

•   A 3D plane with emitter shader is created in Maya, mapped with the HDR light content (RGBA), this can be seen lighting the shot in Render View [Maya|VRay] (see Figure 21).

 

Figure 21: Light converted into an area light

Figure 21: Light converted into an area light

 

STEP 12: Reduce the Smart Dolly slider value to move the light closer to the 3D model (see Figure 22).

 

Figure 22: Moving the area light closer to the model (LightPaint position)

Figure 22: Moving the area light closer to the model (LightPaint position)

 

 

HDR Light Studio has a scene scale setting that is useful when working with Area Lights in Maya. If the area lights are too close or too far away by default. Adjust the Smart Dolly Scalar value in Preferences. This value scales all area lights in HDR Light Studio.

If we switch to the Maya user interface, we can see:

 

•   The Area Light geometry in the viewport (see Figure 23) (If not, the area light is most likely too far away from your scene. To learn more about Smart Dolly - click here)  

•   A folder containing the area lights made with HDR Light Studio in the Outliner (see Figure 23)

•   Area Light setup in the Attributes panel for the created area lights - mapped with HDR (RGBA) content (see Figure 23)

 

Figure 23: Maya interface after creating an area light

Figure 23: Maya interface after creating an area light

 

STEP 13: Use LightPaint in the Render Views to move the Area Lights, just like moving a light on the HDRI map (see Figure 24).

In fact, area lights are controlled just like any other light in HDR Light Studio, with the addition of distance settings.

 

Figure 24: Using LightPaint to position the area light

Figure 24: Using LightPaint to position the area light

When using the HDR Light Studio area lights, please note:
Renaming/deleting/duplicating these area lights in Maya (or any part of their associated shader network/file nodes) will cause problems!

STEP 14: Enable Fast Area Light setting in the Render View panel  (25) for fast noise removal on very big scenes (see Figure 26).

Figure 25: Fast Area Light checkbox

Figure 25: Fast Area Light checkbox

Figure 26: Painting area lights with Area Light Setting On (left) and Off (right)

Figure 26: Painting area lights with Area Light Setting On (left) and Off (right)

STEP 15: Once you are happy with your lighting, press the 'Production Render' button in HDR Light Studio (see Figure 27).

 

Figure 27: Production Render buttons

Figure 27: Production Render buttons

 

Set your Production Render settings and Press Render in this panel. Notice how the 'Orientation' is already set to 'Maya/VRay', this ensures that the rendered HDRI map is mapped correctly in the host, i.e. Maya (see Figure 28). For more information see: Production Render Dialog

 

Figure 28: Production Render Panel

Figure 28: Production Render Panel

 

The production quality content will be calculated and saved. The connection will automatically update Maya to use these final area lights and HDRI map images.
 
If any further changes are now made to the lighting in HDR Light Studio, all content will be updated to use the updated proxy versions again.
 
So please ensure you 'Stop' the HDR Light Studio connection after you have produced your production lighting, by Pressing the Stop button (see Figure 29).

 

Figure 29: Stopping the HDR Light Studio connection

Figure 29: Stopping the HDR Light Studio connection

 

STEP 16: Save Maya scene.

If you would like the HDR Light Studio project to be saved in your Maya scene, you should save your Maya scene now. This way the scene state matches the HDRI map and area lights that are currently in the project.

 

STEP 17: The below explains how to save and load HDR Light Studio projects

HDR Light Studio projects can be saved from the HDR Light Studio interface at any time during the lighting process as a HDi file (native HDR Light Studio project file), even when using HDR Light Studio via a connection. If you were to open HDR Light Studio in a connection with Maya, this project can be loaded into HDR Light Studio using Project > Open Project. The lighting design would load into HDR Light Studio replacing its current design, and would then be synced back into Maya. This is how you can move lighting designs between Maya projects or between other supported 3D software / renderers.

 

 

 

 

 

 

©2009-2021 Lightmap Ltd - For support email: support@lightmap.co.uk