Please enable JavaScript to view this site.

HDR Light Studio - Documentation

HDR Light Studio is a standalone lighting application providing a set of tools and content dedicated to lighting 3D scenes. Using HDR Light Studio connected to Maya provides the ability to create custom HDRI maps to light your scenes, with lights chosen and positioned to provide the perfect effect on your model. As you work with HDR Light Studio, the lighting is updated in real-time in Maya, where you can see the lighting interact with your 3D scene. You can also create and control Area Lights using HDR Light Studio.

This workflow tutorial will teach you how to use the connection between Maya and HDR Light Studio.
It will not teach you how to use HDR Light Studio itself. Please see our 'Getting Started' content here to learn the HDR Light Studio interface and the basic features.

Workflow Tutorial
Requirements: Maya 2019 / 2020 / 2022 with Maxwell. Not your Maya version or renderer? Click here to see Workflow - Method 1

STEP 1: Start Maya and load the Maya project you want to light (see Figure 1).

 

Make sure a camera is set up for your scene and your correct renderer is set. In this example Maxwell Render is used.

 

Figure 1: Loaded scene in Maya

Figure 1: Loaded scene in Maya

 

STEP 2: When using Maxwell Render, the image based lighting needs to be manually set. If you are not using Maxwell Render, you can skip this step and continue to Step 3.

 

Go to Windows > Rendering Editors > Render Settings, while the Maxwell Render tab is open, in the Maxwell Render Environment section, ensure 'Use Image Based Environment' tick box is on. Load any HDRI map (hdr or exr) into the Background Texture slot and ensure 'Spherical Mapping' tick box is on (see Figure 2).

 

Figure 2: setting up image based lighting

Figure 2: setting up image based lighting

An IBL Hook is now created. Close Render Settings Panel.

 

STEP 3: Open the HDRLightStudio Connection shelf.
 
If you do not see the HDRLightStudio shelf, click here to see installation instructions.
 
The HDRLightStudio shelf opens (see Figure 3)

 

Figure 3: HDR Light Studio connection tab

Figure 3: HDR Light Studio connection tab

 

STEP 4: In the HDRLIghtStudio connection shelf, click on the 'Start' button (see Figure 4)

 

Figure 4: Starting the HDR Light Studio connection by clicking on the 'Start' button

Figure 4: Starting the HDR Light Studio connection by clicking on the 'Start' button

 

STEP 5: In order for HDR Light Studio to be started in a connection with Maya and your renderer, an IBL Hook is required to connect with.

An IBL Hook is simply a valid Image Based Lighting setup (Dome Light / Environment Light), whose HDRI map file can be replaced and updated by HDR Light Studio.

 

If using Maxwell Render, 'Select Hook for Maxwell' panel opens, click 'Ok' while Background is selected as the hook (see Figure 5). This selects the IBL Hook that was created in Step 2. For any other renderers with no existing hooks, you will be required to create a new IBL Hook by providing a name for the hook in the 'Create New Hook for x' panel and press the OK button (see Figure 6).

 

Figure 5: Selecting an existing IBL hook for Maxwell Render

Figure 5: Selecting an existing IBL hook for Maxwell Render

 

Figure 6: Creating a new IBL hook

Figure 6: Creating a new IBL hook

 

HDR Light Studio will then start connected to the hook selected (see Figure 7).
 
The HDR Light Studio interface will look like in Figure 7.

 

Using our latest version of HDR Light Studio and the Maya connection - the HDR Light Studio interface will now show 2 Render Views. On the left is Render View [Maya|Maxwell] (see Figure 7)

Currently this view is not compatible with Maya Maxwell and can be closed!

 

Figure 7: HDR Light Studio on start up

Figure 7: HDR Light Studio on start up

 

We recommend changing the layout using the top menuWindow > Layout > Load > Default > Standalone

The HDR Light Studio interface will then contain the features you need to use HDR Light Studio with Maya and Maxwell (see Figure 8).

 

Figure 8: HDR Light Studio Standalone interface layout

Figure 8: HDR Light Studio Standalone interface layout

 
When the HDR Light Studio Connection starts, a HdrlsProjectData node is added to the Maya scene and can be seen in the Outliner (see Figure 9).

This node stores the HDR Light Studio lighting project within the Maya scene so that the lighting design can be restored in HDR Light Studio in future sessions.

This stores the last state of the project before the HDR Light Studio connection is closed, and of course is only saved when the Maya scene itself is saved.

 

Please note: Using Maya's 'File > Optomize Scene Size' feature will remove the HdrlsProjectData node from your scene. Be sure not to accidentally remove it.

 

Figure 9: HdrlsProjectData node shown in the outliner

Figure 9: HdrlsProjectData node shown in the outliner

 

The current HDRI map design in HDR Light Studio is shared with Maya as a temp proxy (lo-res) image. A proxy is used because it's faster to calculate and faster for Maya to load during the iterative lighting design process. When the lighting design changes in HDR Light Studio, this image is updated in Maya to use a new temp with a new file name, to ensure the renderer uses the new image even when caching images.

 

The temporary file name and location will look something like in Figure 10. 

 

Figure 10: Location of the temp proxy (lo-res) image

Figure 10: Location of the temp proxy (lo-res) image

 

STEP 6: Using 2 displays provides the best work flow, with HDR Light Studio on one display, and Maya on the other (see Figure 11). Press the play button on Render View [HDR Light Studio] (see Figure 12).

 

Figure 11: Maya (left) and HDR Light Studio (right) running on 2 displays

Figure 11: Maya (left) and HDR Light Studio (right) running on 2 displays

 

 

Figure 12: Starting HDR Light Studio Render View

Figure 12: Starting HDR Light Studio Render View

 

The Import Scene Geometry panel will pop up.

 

STEP 7: Press Import (see Figure 13)

 

Figure 13: Importing the scene from Maya to HDR Light Studio render view

Figure 13: Importing the scene from Maya to HDR Light Studio render view

 

 

We will use this Render View in HDR Light Studio as the interface for positioning lights on the model, with real time feedback (see Figure 14).

 

Figure 14: HDR Light Studio render view with imported scene from Maya

Figure 14: HDR Light Studio render view with imported scene from Maya

 

Let's make our first light in HDR Light Studio ...

By default, LightPaint is set to Reflection in this view. So lights are positioned to reflect in the chosen location on the 3D model when using LightPaint (see Figure 15).

Learn about LightPaint here.

 

Figure 15: LightPaint mode set to Reflection

Figure 15: LightPaint mode set to Reflection

 

 

STEP 8: Drag and drop a Preset Light onto the 3D model in the Render View (see Figure 16)

 

Figure 16: Placing a preset light onto the model

Figure 16: Placing a preset light onto the model

 

The Preset Light has been added to the lighting design in a location that is reflecting where the light was dropped on the 3D model.

You will see:

A new light in the Light List in HDR Light Studio (see Figure 17).

You can see the new light added on the Canvas (HDRI Map View) in HDR Light Studio (see Figure 17).

The Render View has been updated to show the lighting effect on the loaded 3D model (see Figure 17).

Figure 17: HDR Light Sutido interface after creating a light

Figure 17: HDR Light Sutido interface after creating a light

You can see that the LightPaint tool is active in the toolbar within the Render View [HDR Light Studio] (see Figure 18).

STEP 9: Click on the 3D model to reposition the selected light from the Light List.
This is a very interactive way to light your shot. Placing lights directly on the 3D model where you want them (see Figure 18).

Figure 18: Using LightPaint to paint light on the model

Figure 18: Using LightPaint to paint light on the model

STEP 10: Let's start Maxwell interactive rendering in Maya to see what the lighting looks like (see Figure 19).

Figure 19: Starting Maxwell interactive rendering in Maya

Figure 19: Starting Maxwell interactive rendering in Maya

Maxwell Frame Buffer opens and Maxwell starts rendering the view (see Figure 20).

Figure 20: Maxwell frame buffer inside Maya (left) running with HDR Light Studio (right) 

Figure 20: Maxwell frame buffer inside Maya (left) running with HDR Light Studio (right) 

We can leave Maxwell rendering as we work in HDR Light Studio. When lighting changes in HDR Light Studio, it will update Maya > Maxwell to use the new lighting.
If the scene is large and rendering in Maxwell is updating slowly, you can produce test renders from time to time instead of leaving Maxwelll interactive rendering running. It is up to the user to judge this performance and decide what to do.

So far the light we created is on the HDRI map. With a single setting, this light can be removed from the HDRI map, and created as an Area Light in 3D space in Maya, mapped with the HDR content from HDR Light Studio.

STEP 11: Enable the Area Light check box in the Light Properties panel for the selected light (see Figure 21).

Figure 21: Converting a light into an area light

Figure 21: Converting a light into an area light

 

As a result of enabling the Area Light setting, these things instantly happen:

•   The Light in the Light List gets the suffix [AreaLight] and the text is now yellow - clearly showing which lights are Area Lights (see Figure 22).

•   The light is removed from the HDRI map lighting the Render Views (but is still represented and shown on the Canvas) (see Figure 22).

•   A 3D Area Light mapped with the HDR light content (RGBA) is created in HDR Light Studio with a Smart Dolly distance of 1,000 (see Figure 22).

•   A 3D plane with emitter shader is created in Maya, mapped with the HDR light content (RGBA), this can be seen lighting the shot in Render View [HDR Light Studio] (see Figure 22).

Figure 22: Light converted into an area light

Figure 22: Light converted into an area light

STEP 12: Reduce the Smart Dolly slider value to move the light closer to the 3D model (see Figure 23).

Figure 23: Moving the area light closer to the model (LightPaint position)

Figure 23: Moving the area light closer to the model (LightPaint position)

 

 

HDR Light Studio has a scene scale setting that is useful when working with Area Lights in Maya. If the area lights are too close or too far away by default. Adjust the Smart Dolly Scalar value in Preferences. This value scales all area lights in HDR Light Studio.

If we switch to the Maya user interface, we can see:

 

•   The Area Light geometry in the viewport (see Figure 24) (If not, the area light is most likely too far away from your scene. To learn more about Smart Dolly - click here)  

•   A folder containing the area lights made with HDR Light Studio in the Outliner panel (see Figure 24)

•   Area Light setup in the Attributes panel for the created area lights - mapped with HDR (RGBA) content (see Figure 24)

 

Figure 24: Maya interface after creating an area light

Figure 24: Maya interface after creating an area light

 

STEP 13: Use LightPaint in the Render View [HDR Light Sutdio] to move the Area Lights, just like moving a light on the HDRI map (see Figure 25).

In fact, area lights are controlled just like any other light in HDR Light Studio, with the addition of distance settings.

 

Figure 25: Using LightPaint to position the area light

Figure 25: Using LightPaint to position the area light

 
Rather than guessing where to put the lights in HDR Light Studio to achieve your desired effect, a selected light in HDR Light Studio can be moved using the LightPaint tools in the HDR Light Studio Connection shelf. Press one of the LightPaint mode names to enable the tool. Then click on the 3D model in the Maya viewport to position the light via that LightPaint mode. Press the Off button to stop the LightPaint tool.

For more information about the LightPaint modes see: LightPaint

Figure 25: LightPaint tools in the HDR Light Studio Connection shelf

Figure 25: LightPaint tools in the HDR Light Studio Connection shelf

 

When using the HDR Light Studio area lights, please note:
Renaming/deleting/duplicating these area lights in Maya (or any part of their associated shader network/file nodes) will cause problems!

STEP 14: Enable Fast Area Light setting in the Render View panel  (26) for fast noise removal on very big scenes (see Figure 27).

Figure 26: Fast Area Light checkbox

Figure 26: Fast Area Light checkbox

Figure 27: Painting area lights with Area Light Setting On (left) and Off (right)

Figure 27: Painting area lights with Area Light Setting On (left) and Off (right)

 

STEP 15: Once you are happy with your lighting, press the 'Production Render' button in HDR Light Studio (see Figure 28).

 

Figure 28: Production Render buttons

Figure 28: Production Render buttons

 

Set your Production Render settings and Press Render in this panel. Notice how the 'Orientation' is already set to 'Maya/Maxwell', this ensures that the rendered HDRI map is mapped correctly in the host, i.e. Maya (see Figure 29). For more information see: Production Render Dialog

 

Figure 29: Production Render Panel

Figure 29: Production Render Panel

 

The production quality content will be calculated and saved. The connection will automatically update Maya to use these final area lights and HDRI map images.
 
If any further changes are now made to the lighting in HDR Light Studio, all content will be updated to use the updated proxy versions again.
 
So please ensure you 'Stop' the HDR Light Studio connection after you have produced your production lighting, by Pressing the Stop button (see Figure 30).

 

Figure 30: Stopping the HDR Light Studio connection

Figure 30: Stopping the HDR Light Studio connection

 

STEP 16: Save Maya scene.

If you would like the HDR Light Studio project to be saved in your Maya scene, you should save your Maya scene now. This way the scene state matches the HDRI map and area lights that are currently in the project.

 

STEP 17: The below explains how to save and load HDR Light Studio projects

HDR Light Studio projects can be saved from the HDR Light Studio interface at any time during the lighting process as a HDi file (native HDR Light Studio project file), even when using HDR Light Studio via a connection. If you were to open HDR Light Studio in a connection with Maya, this project can be loaded into HDR Light Studio using Project > Open Project. The lighting design would load into HDR Light Studio replacing its current design, and would then be synced back into Maya. This is how you can move lighting designs between Maya projects or between other supported 3D software / renderers.

©2009-2021 Lightmap Ltd - For support email: support@lightmap.co.uk