Please enable JavaScript to view this site.

HDR Light Studio - Documentation

Navigation: HDR Light Studio

Getting Started

Scroll Prev Top Next More

This section covers the basics to get your started with HDR Light Studio. You will learn how to load a model, light the model, render and save a high dynamic range image and quit the application. It should take about 5 minutes to read through this section. For more detailed information on HDR Light Studio, see the Reference section.

User Interface Overview

After starting HDR Light Studio, you will see the main application window. The layout should look something like this.

HDR Light Studio user interface showing main panels. 

HDR Light Studio user interface showing main panels.

Light List
This panel shows a list of the lights used to illuminate the model.
 
Light Properties
This panel shows the editable properties of the selected light (position, color, size, etc)
 
Render View Settings
This panel shows the settings for the Render View (shader settings, resolution, etc)
 
Presets
This panel shows a thumbnail view of a wide range of preset light sources. To add a light to your lighting design, just drag it from this panel to the Canvas, Light List or 3D model in the Render View.
 
Canvas
This panel shows all lights on a lat-long HDRI map.
 
Light Controls
Click, hold and drag on these buttons to scale, rotate and change the brightness of the selected light.
 
Render View
Shows a rendered lighting preview of the loaded 3D scene lit with your lighting design.
 
Light Preview
Displays the image content of the currently selected light.
 
Toolbars
Buttons for light new creation, as well as buttons to add, duplicate and delete lights, undo, redo, render and get help.

Loading a Model

The easiest way to load a 3D scene is to Press the Play button on the Render View and you can choose a demo scene or load a file - Alembic, Collada, FBX (Windows only) or Mental Images scenes are supported.

Alternatively there are 3 other methods
1. In the menu, go to Project > Load 3D Scene File
2. Drag and drop a scene file from your file system browser directly onto the Render View
3. In the Render Settings panel, press the Browse button next to 3D Scene File to locate and choose a scene

load_model_r2

Lighting the Model

Click on the toolbar to add a synthetic round light. It will be added to the centre of the canvas. Move the light by clicking on the canvas or the model. You can add picture lights from the Presets panel by clicking and dragging to the canvas or model.

lightingthemodel

Each light that is added is shown in the Light List. The order in which they are drawn on the canvas is determined by their position in the light list. To change the size or brightness of a light, first select the light in the light list, then use the buttons in the Light Controls panel or edit their numeric values in the Light Properties panel. Use the Edit menu to delete or duplicate lights.

Light Controls and Light Properties panels 

Light Controls and Light Properties panels

 

Rendering the Canvas

Once you are happy with your lighting design, you need to render the HDR canvas at a high pixel resolution and save that image file to disk. Press the HDR Render button on the toolbar, edit the settings in the Production Render dialog and press Render.

Production Render Dialog 

Production Render Dialog

The resulting high resolution, high dynamic range image file should be used in your 3D application (Maya, 3ds Max, etc) as an environment map to light your model.

Saving the Project
You may find that you need to adjust your lighting design having viewed the final render in your 3D application.To do this you should save your HDR Light Studio project. Just select Save Project from the Project menu.

Quitting the Application
You can exit the application from the Project menu selecting Exit.

 

 

 

©2009-2018 Lightmap Ltd - For support email: support@lightmap.co.uk