Please enable JavaScript to view this site.

HDR Light Studio - Documentation

HDR Light Studio is a standalone lighting application providing a set of tools and content dedicated to lighting 3D scenes. Using HDR Light Studio connected to Cinema 4D provides the ability to create custom HDRI maps to light your scenes, with lights chosen and positioned to provide the perfect effect on your model. As you work with HDR Light Studio, the lighting is updated in real-time in Cinema 4D, where you can see the lighting interact with your 3D scene. You can also create and control Area Lights using HDR Light Studio.

This workflow tutorial will teach you how to use the connection between Cinema 4D and HDR Light Studio.
It will not teach you how to use HDR Light Studio itself. Please see our 'Getting Started' content here to learn the HDR Light Studio interface and the basic features.

Workflow Tutorial
Requirements: Cinema 4D R20 with Arnold, Octane, Redshift or Thea Render. Not your Cinema 4D version or renderer? Click here to see Workflow - Method 2
 
For compatibility ensure you are running 'at least' these renderer builds:
Octane Version: 2018.1.3 (Octane 5) or 4.04-R2 (Octane 4)
Arnold Version: 2.5.0
Redshift Version: 2.6.40
Thea Version:    2.1.457.1847

1. Start Cinema 4D and load the Cinema 4D project you want to light.

2. Open the HDRLightStudioC4D Connection plugin panel
Go to the menu: Plugins > HDRLightStudioC4D Connection (see Figure 1)

Figure 1: Opening the HDRLightStudioC4D Connection plugin panel

Figure 1: Opening the HDRLightStudioC4D Connection plugin panel

The HDRLightStudioC4D panel opens (see Figure 2).

Figure 2: HDRLightStudioC4D Connection Plugin panel

Figure 2: HDRLightStudioC4D Connection Plugin panel

Drag the panel and dock it into the C4D interface (see Figure 3).

Figure 3: Docked HDRLightStudioC4D Connection Plugin panel in the C4D interface

Figure 3: Docked HDRLightStudioC4D Connection Plugin panel in the C4D interface

3. Use the 'Renderer' drop down in the Connection panel to select the Renderer being used for this project.
In this example we are using Octane Render (see Figure 4).

4: Choosing the renderer

4: Choosing the renderer

4. Press the 'Add Prebuilt Hook' button (see Figure 5).
This will create a new lighting environment setup for your chosen renderer that's set up so the HDR Light Studio connection will see and can control the environment image.

Figure 5: Adding a prebuilt hook

Figure 5: Adding a prebuilt hook

Here you can see the HDRLightStudio.Octane node has been created and contains the environment setup for Octane Render.
This is listed as the selected Environment Hook by the HDR Light Studio Connection (see Figure 6).

Figure 6: HDRLightStudio.Octane node created

Figure 6: HDRLightStudio.Octane node created

5. Make sure you are looking through the Camera you want to light in the Cinema 4D interface, with that viewport active.
 
We are now ready to start using HDR Light Studio
6. Press 'Start' to start HDR Light Studio connected with Cinema 4D (see Figure 7)

Figure 7: Starting HDR Light Studio connection

Figure 7: Starting HDR Light Studio connection

The HDR Light Studio application will open and is now connected to Cinema 4D.
The HDR Light Studio connection has taken control of the image on the environment (see Figure 8).

Figure 8: File path points to a HDR Light Studio temp proxy image

Figure 8: File path points to a HDR Light Studio temp proxy image

The current HDRI map design in HDR Light Studio is shared with Cinema 4D as a temp proxy (lo-res) image. A proxy is used because it's faster to calculate and faster for Cinema 4D to load during the iterative lighting design process. When the lighting design changes in HDR Light Studio, this image is updated in Cinema 4D to use a new temp with a new filename, to ensure the renderer uses the new image even when caching images.

The HDR Light Studio interface should look like Figure 9.
If not in HDR Light Studio you can reset it by going to the menu: Window > Layout > Load > Default > Cinema 4D

Figure 9: HDR Light Studio on startup with Cinema 4D

Figure 9: HDR Light Studio on startup with Cinema 4D

Using our latest version of HDR Light Studio and the Cinema 4D connection - the HDR Light Studio interface will now show 2 Render Views.

On the left is Render View [Cinema 4D|Octane] (New in Tungsten Drop 2)

7. Press Play on Render View [Cinema 4D|Octane] (see Figure 10)

Figure 10: Starting the Octane Render View within HDR Light Studio

Figure 10: Starting the Octane Render View within HDR Light Studio

HDR Light Studio now instructs Cinema 4D to start an interactive render session with the current renderer.
The interactive render image is now displayed in this Render View (see Figure 11).
To understand all of the features/controls for this view, see here.

Please Note: When using Arnold Render, HDR Light Studio starts a 'hidden' interactive render. To avoid problems, DO NOT use the Arnold IPR window in C4D when using HDR Light Studio to display the Arnold interactive render.

Figure 11: Octane render view working within HDR Light Studio

Figure 11: Octane render view working within HDR Light Studio

Let's make our first light in HDR Light Studio ...

By default, LightPaint is set to Reflection in this view. So lights are positioned to reflect in the chosen location on the 3D model when using LightPaint (see Figure 12).
Learn about LightPaint here.

Figure 12: LightPaint mode set to Reflection

Figure 12: LightPaint mode set to Reflection

Please note: Make the camera “editable” for Rim Lightpaint mode to work in this view. For example, if you use a camera from an alembic file, its not a "real" camera in Cinema 4D and does not have all the properties of the camera exposed. When you "make editable" it creates all the regular camera properties that HDR Light Studio requires for Rim lighting mode.

8. Click on the Presets tab next to the Light List tab, to show the Preset Lights (see Figure 13).

Figure 13: Opening the presets tab to see a list of presets

Figure 13: Opening the presets tab to see a list of presets

9. Drag and drop a Preset Light onto the 3D model in the Render View [Cinema 4D|Octane] (see Figure 14).

Figure 14: Placing a preset light onto the model

Figure 14: Placing a preset light onto the model

The Preset Light has been added to the lighting design in a location that is reflecting where the light was dropped on the 3D model.

You will see:

A new light in the Light List in HDR Light Studio (see Figure 15).

You can see the new light added on the Canvas (HDRI Map View) in HDR Light Studio (see Figure 15).

The Cinema 4D environment has been updated to use the new live HDRI map from HDR Light Studio, and the renderer in C4D updated to use the new lighting (see Figure 15).

Figure 15: HDR Light Studio interface after creating a light

Figure 15: HDR Light Studio interface after creating a light

You can see that the LightPaint tool is active in the toolbar within the Render View [Cinema 4D|Octane] (see Figure 16).

10. Click on the 3D model to reposition the selected light from the Light List (see Figure 16).
The light is moved on the HDRI map, the new HDRI map is sent to Cinema 4D and the interactive render updates.
This is a very interactive way to light your shot. Placing lights directly on the 3D model where you want them.

Figure 16: Using LightPaint to paint lights on the model

Figure 16: Using LightPaint to paint lights on the model

If there is a delay of more than a second, or so, after clicking to move a light and see the updated rendered result - the process will be slow and tedious.
In this situation we can use HDR Light Studio's built in renderer to speed up the lighting process.

11. Press the play button on Render View [HDR Light Studio] (see Figure 17)

Figure 17: Starting up HDR Light Studio Render View

Figure 17: Starting up HDR Light Studio Render View

The Import Scene Geometry panel will pop up

12. Press Import (see Figure 18)

Figure 18: Importing the scene from Cinema 4D to HDR Light Studio render view

Figure 18: Importing the scene from Cinema 4D to HDR Light Studio render view

By default the whole Cinema 4D scene is exported as a temporary alembic file and loaded into the Render View [HDR Light Studio].

You may need to use the Camera Drop Down in Render View [HDR Light Studio] to match the camera view you are seeing from Cinema 4D (see Figure 19).

Figure 19: Octane render view (left) and HDR Light Studio render view (right) side by side

Figure 19: Octane render view (left) and HDR Light Studio render view (right) side by side

The Render View [HDR Light Studio] renders the loaded scene lit with the current lighting design. A simple shader is used on the whole scene to preview the light and reflections.
If you needed to open Render View [HDR Light Studio] to get a more interactive lighting experience. Use this view for LightPaint, where clicking and dragging to position lights is supported - it's fast and interactive.
The Render View [Cinema 4D|Octane] rendering will catch up eventually as you work, and will display an image using the latest lighting.

If the Render View [Cinema 4D|Octane] is still so slow that it is of little benefit during the interactive lighting process, and maybe it is also slowing down HDR Light Studio a lot, then use the Pause/Play button to stop and resume rendering in Render View [Cinema 4D|Octane], in order to do test renders from time to time (see Figure 20).

Figure 20: Pause/Play button for the render view

Figure 20: Pause/Play button for the render view

We have documented in more detail the process of using 2 render views together in HDR Light Studio here.

So far the light we created is on the HDRI map. With a single setting, this light can be removed from the HDRI map, and created as an Area Light in 3D space in Cinema 4D, mapped with the HDR content from HDR Light Studio.

13. Enable the Area Light check box in the Light Properties panel for the selected light (see Figure 21).

Figure 21: Converting a light into an area light

Figure 21: Converting a light into an area light

As a result of enabling the Area Light setting, these things instantly happen:

The Light in the Light List gets the suffix [AreaLight] and the text is now yellow - clearly showing which lights are Area Lights (see Figure 22).

The light is removed from the HDRI map lighting the Render Views (but is still represented and shown on the Canvas) (see Figure 22).

A 3D Area Light mapped with the HDR light content (RGBA) is created in HDR Light Studio with a Smart Dolly distance of 1,000 (see Figure 22).

A 3D plane with emitter shader is created in Cinema 4D, mapped with the HDR light content (RGBA), this can be seen lighting the shot in Render View [Cinema 4D|Octane] (see Figure 22).

Figure 22: Light converted into an area light

Figure 22: Light converted into an area light

14. Reduce the Smart Dolly slider value to move the light closer to the 3D model (see Figure 23).

Figure 23: Moving the area light closer to the model (LightPaint position)

Figure 23: Moving the area light closer to the model (LightPaint position)

HDR Light Studio has a scene scale setting that is useful when working with Area Lights in Cinema 4D. If the area lights are too close or too far away by default. Adjust the Smart Dolly Scalar value in Preferences. This value scales all area lights in HDR Light Studio.

If we switch to the Cinema 4D user interface, we can see:

The Area Light geometry in the viewport (see Figure 24) (If not, the area light is most likely too far away from your scene. To learn more about Smart Dolly - click here)  

Any area lights made with HDR Light Studio are listed under the HDRLS Env (see Figure 24)

Shaders setup for the area light, mapped with HDR (RGBA) content (see Figure 24)

 

Figure 24: Cinema 4D interface after creating an area light

Figure 24: Cinema 4D interface after creating an area light

15. Use LightPaint in the Render Views to move the Area Lights, just like moving a light on the HDRI map (see Figure 25).
In fact area lights are controlled just like any other light in HDR Light Studio, with the addition of distance settings.

Figure 25: Using LightPaint to position the area light

Figure 25: Using LightPaint to position the area light

When using the HDR Light Studio area lights, please note:
Renaming/deleting/duplicating these area lights in Cinema 4D (or any part of their associated shader network/file nodes) will cause problems!

16. Production Render
Once you are happy with your lighting, press the 'Production Render' button in HDR Light Studio (see Figure 26).

Figure 26: Production Render buttons

Figure 26: Production Render buttons

 
Set your Production Render settings and Press Render in this panel. Notice how the 'Orientation' is already set to 'Cinema 4D/Octane', this ensures that the rendered HDRI map is mapped correctly in the host, i.e. Cinema 4D (see Figure 27). For more information see: Production Render Dialog

Figure 27: Production Render Panel

Figure 27: Production Render Panel

The production quality content will be calculated and saved. The connection will automatically update Cinema 4D to use these final area light and HDRI map images.

If any further changes are now made to the lighting in HDR Light Studio, all content will be updated to use the updated proxy versions again.
So please ensure you 'Stop' the HDR Light Studio connection after you have produced your production lighting, by Pressing the Stop button (see Figure 28).

Figure 28: Stopping the HDR Light Studio connection

Figure 28: Stopping the HDR Light Studio connection

17. Save Cinema 4D scene.
If you would like the HDR Light Studio project to be saved in your Cinema 4D scene, you should save your Cinema 4D scene now. This way the scene state matches the HDRI map and area lights that are currently in the project.

18. Saving and loading HDR Light Studio projects
HDR Light Studio projects can be saved from the HDR Light Studio interface at any time during the lighting process as a HDi file (native HDR Light Studio project file), even when using HDR Light Studio via a connection. If you were to open HDR Light Studio in a connection with Cinema 4D, this project can be loaded into HDR Light Studio using Project > Open Project. The lighting design would load into HDR Light Studio replacing its current design, and would then be synced back into Cinema 4D. This is how you can move lighting between Cinema 4D projects or between other supported 3D software.

 

 

©2009-2018 Lightmap Ltd - For support email: support@lightmap.co.uk